maxscript morph not working

ive already checked a number of posts about it and tried checking other scripts online but cant find a nice simple way to get done what i want to do.

this is more or less where im at now (sorry about the formatting but this forum wont allow it to scroll horizontally

rollout Facial "Controls" width:512 height:434
button Ra_Delete "X" pos:[62,54] width:13 height:15
spinner Ra "Ra" pos:[38,30] width:62 height:16 range:[0,1000,1] type:#worldunits controller: ($Sphere01.radius.controller) --works as expected where the spinner controls the radius
spinner MM "MM" pos:[118,30] width:62 height:16 range:[0,100,0] type:#float controller: (WM3_MC_GetValue $Box01.modifiers[#Colonel_Face_Morpher] 1)--does not work to have the spinner control slot1 in the morpher modifier.
button MM_Delete "X" pos:[142,54] width:13 height:15
GroupBox Mouth_G "Mouth" pos:[7,11] width:495 height:155

on Ra_Delete pressed do
selecetKeys $Sphere01.radius.controller [time ((currentTime as integer)/TicksPerFrame)]--doesnt work, need to be able to select the radius keys at the current time (would also like to have a check to see if there are indeed keys at that time and do nothing if not)
deleteKeys $Sphere01.radius.controller #selection--this would work if the line above worked

on MM_Delete pressed do --nothing in here works since the morpher spinner above doesnt work either
selecetKeys $Box01.modifiers[#Colonel_Face_Morpher] 1 [time ((currentTime as integer)/TicksPerFrame)]
deleteKeys $Box01.modifiers[#Colonel_Face_Morpher] 1 #selection

Anim_Controls = newRolloutFloater "Animation Controls" 560 490
addRollout Facial Anim_Controls