Sublime Text Editor - MXS support


Is there anyone who has looked at opportunities to get support for the MXS to the Sublime Text Editor? (

I have not investigated this much, but this should probably be able to do?

I see it already is language defenition files to notepad++ here(Notepad++ MXS Language Definition)

Have any of you tips, tricks and suggestions around this they would have been received with great thanks.


Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
br0t's picture

Alternate approach:

Alternate approach: Sublime3dsMax

Never get low & slow & out of ideas

barigazy's picture

Just follow instructions from

Just follow instructions from this .pdf
I modify previous attachment

darkscintilla_autocomplete.rar 1.86 MB
instruction.pdf 1.96 MB


crimsondesigns's picture


This is awesome.
Thanks for the great work!

captainkeytar's picture

I just created a MaxScript language definition for SublimeText

Haven't had a chance yet to properly host on GitHub/Package Control, but here's v0.1. It's a first pass and there's still numerous things I'd like to add, but I'm new to language definitions so some of that will take some more figuring out on my part.

Please let me know if this works for you, or not :)

Just unzip that to your Package dir in a directory called /MaxScript/


TracyMa's picture

Works well

you save my time! It will be Better if in package controll system.

haavards's picture

Running scripts from Sublime Text

I took the liberty of adding some files to your Maxscript package to Sublime Text so you can run maxscripts from Sublime. To make it work you have to copy "Autodesk.Max.dll" and "Autodesk.Max.Remoting.dll" from your max root folder to the Maxscript folder. Note, for this to work in versions previous to Max2013 you need to download the .Net wrappers from If you got Max2013 you already got this installed. The last thing is to edit the \Users\username\AppData\Local\Autodesk\3dsMax\2013 - 64bit\ENU\en-US\plugcfg\MaxDotNet.config file and set AllowRemoting to true.

To assign a hotkey for running scripts, edit the "Default (Windows).sublime-keymap.json" file. You can also run it using Tools\Maxscript from the menu.

The files:

Kif's picture

Running scripts from Sublime

Thank you!

l0op1ng's picture

Hi, And first thanks Haavards


And first thanks Haavards for the maxscript support in sublime.
I create a package with everything you said and install it in sublime.

Syntax color works very well.
I have the tool \ max script command but when i click on it nothing happens (after a short wait)

Could you describe a little more how to be able to execute maxscript for sublime please ?

PS : I am using 3ds max 2013 64 bits.


haavards's picture

Not sure what could be wrong

Not sure what could be wrong if there are no error messages popping up.

Here is a procedure to check if the remoting is properly set up:

First, be sure to copy the two .dll-files from your max root directory to the maxscript package folder.

Secondly, be sure to have enabled remoting as described in my first post, the two fields to check in the MaxDotNet.config file should look like this:



Then with Max open, go to the package folder and open up a cmd window at that location. A quick way to do that is to go to the parent folder and shift+right click on the folder and choose "Open command window here". Then enter

MXSSublime "teapot()" 

This calls the .exe file with a simple script. If it's set up correctly you should have a teapot in your scene.

This is basically what the python script does when calling it from the sublime editor. If the remoting works and the script fails it should display an error message in Max's listener as usual.

Try running sublime text as an administrator if it still does not work.

pepetd's picture

I am having a hard time

I am having a hard time getting it to work with sublime 2, I place the maxscript folder inside the pristine packages folder and it doesn't work.

I also tried making a packages folder at the sublime root directory and it doesn't work.

Any ideas?

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.