Viewport quality control

Hello,

Is it possible in maxscript to set all your viewports to “standard” instead of “user defined”?
User defined is very annoying for us at the office.

Thank you.

best,
Remy

AttachmentSize
34d39600-ea42-49ef-9c50-d99d5c4b7c19.jpeg71.42 KB

Comments

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
remykonings's picture

.

Thanks for writing,

Yes that is actually what i already have but it switches during work.
I like to switch to "standard" through maxscript because of another script we already use.
Hopefully that is possible through some programming.

thanks

miauu's picture

.

I don't know why but I can't set any viewport to Standard because such setting not exist.
But open the Maxscirpt listener and delete all text in the pink window. Enalbe the MacroRecorder - turn on the last 3 items in the MacroRecorder menu and then switch the viewport to Standard manually. If something is printed in the Listener (like this one: actionMan.executeAction 0 "550" -- Views: Viewport Visual Style Shaded) then you can use it in your script.

remykonings's picture

.

thank you. that indeed works ) Will this only work on my pc or on other workers pcs too?

miauu's picture

.

It should works on all PCs where the same 3ds Max version is used. In fact it have to works on some of the other 3ds Max versions as well but not on all of them. Sometimes Audotesk changes the command so the command you have got for setting the vpt to Standard may works differently on other 3ds Max version. But you can always use the same method to get the proper command. :)

barigazy's picture

...

try this:
open 3ds max, change all viewports to Standard or any other type, also you can change
viewport layout (your previous post) as you like. Then go and "save as" this empty scene
as "maxstart.max" in "scene" folder

barigazy

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.