Bitmap Blur for Vray Mutlimaterial...

Hi, could someone help me, and post a script, that sets the bitmap blur in VrayMtl for diffuse to 0.1 and for bump slot to 1? And it must work also with multimaterial (subobject materials).

Currently i have 2 scripts (separate), one sets bitmap blur to 0,1 for diffuse slot, and one for bump slot to 1. but they work with suboject material.

Could someone please help me?

Comments

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
barigazy's picture

Try This

Let say your collections of script are placed in maxroot>scripts>MyScripts folder.
First put vraymtl_map_blur_value.ms in this folder,
then create new macro script like this:

macroScript SetBlur category:"MY" internalcategory:"MY" tooltip:"SetBlur" buttontext:"SetBlur" silentErrors:true
(
	local setblurscript = ((getDir #Scripts) + "\\MyScripts\\vraymtl_map_blur_value.ms")
	on execute do ( if not doesFileExist setblurscript then #abort else ( filein setblurscript ) )
)

and save it something like "setblur.mcr" inside
maxroot>UI>MacroScripts folder.
Restart max. Find script and place it on toolbar or quadmenu
If this does not work then the problem is your max installation, not the script.
Use this two files and try.

AttachmentSize
setblur.mcr 302 bytes
vraymtl_map_blur_value.ms 1.13 KB

barigazy

roamn's picture

interesting

it seems to work now, interesting, thanks :-)!

barigazy's picture

Finaly :)

Finaly :)

barigazy

roamn's picture

Little Problem

But how can i put it in the menus (or quads etc.)?

I try to add line

category:"MY" tooltip:"SetBlur" buttonText:"SetBlur" (which i use for all other small scripts i came acros which dont have their own category) but it doesnt help.
If i crate separate launcher ms for it, in which is:

macroScript SetBlur category:"MY" tooltip:"SetBlur" buttonText:"SetBlur"
(
fileIn "vraymtl_map_blur_value.ms"
)

It still doesnt work.

(with "doesnt work" i mean i get a dialogue box where i can only write the bump blur, not the diffuse blur. If i run your script from the run script option everything is ok, but it would help to have it also in max (menu or quad etc.).
What should i add to the begging of the max?

Im using max 2009 64 bit by the way.

barigazy's picture

Old vray

Which version of vray you use.
Try this:
Open maxscript listener and activate macro recorder.
Then open material editor and change diffuse map blur value (material must be VrayMtl).
Look in the listene what is throw. Then send me to see whats goin on.
I use max2012x64 and vray2

barigazy

roamn's picture

It didnt record anything...

it didnt record anything... im having problems with macrorecorder in max 2009, it doesnt, most of the time, record anything.

barigazy's picture

not your record in listener,

not your record in listener, but macroscript file (*.mcr)

barigazy

roamn's picture

i use

Hi, thanks for the updated version.

Well im using vray 1.5 SP4, max 2009 64 Bit, but the problem isnt here probably... Because when i run your script manuly (from maxscript run) it runs and does stuff good.

But when i try to get it to the menus using the "category:" etc. (what i have written before) it allows and show me only one option for the blur...

How can i properly get it to menus or quads please?

barigazy's picture

post or attach your

post or attach your macroscript here and i'll try to fix it

barigazy

roamn's picture

ok

I created a new *.ms file, i use it to add your script to category in max Customize, the script is:

macroScript SetBlur category:"MY" tooltip:"SetBlur" buttonText:"SetBlur"
(
fileIn "vraymtl_map_blur_value.ms"
)

On the left you can the dialogue whioch appears when i run the script from maxscript run and right you can see the dialogue which appears when i load your script with my new short filein script (As listed sbove):

http://s16.postimage.org/v86iipodh/Untitled_1.jpg

Wheres the problem? all i want to do is to add your fully functional script to menu (or quad) what should i do please?

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.