snap zoom lag...

Hi there to all readers.. :)

I am facing a problem in heavy scenes
Whenever I zoom while snap is on the scene/viewport/3ds max freezes...
This happens ONLY when move tool is selected and snaps are on.

I dont know if this has been solved or not.. but here is a workaround I thought about..
Do correct me if I am wrong..

The script should do the following -
Switch to "Select Tool" on "zoom in/out start" and switch back to move tool on "zoom in/out stop".
OR - in layman's terms -
whenever scrolling takes place in the viewport, if move tool and snaps are ON - switch to select tool.
after scrolling stops switch back to move tool if move tool and snaps were orginally ON..

Do you think this a valid workaround... ??

As this could be always required - A script that can be placed in the startup scripts folder would be great..

Comments

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
jahman's picture

.

Just make yourself a macro for snaps toggle that would switch move tool to something else

ChinmayT's picture

Thank you for the reply Jahman

Hi jahman thank you for the reply

and thanks for the suggestion

The thing is that I dont know any coding..
If you could share the code for your suggestion it would be great..

Regards.

miauu's picture

...

No need of coding. When you turn On the snap just hit the Q key and 3ds max will switch to Smart Select Tool. Then pan and zoom the viewport.

ChinmayT's picture

# Correction...

I Apologize for any inconvenience..

Correction for original post -

This is happening when snaps are on and cursor moves....

So can a script be for this -

IF snaps are ON with move tool ON

and cursor moves in viewport - switch to select tool
on cursor move stop switch back to move tool
(only in viewport)

Thank you!

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.