Rock Generator

257 votes
Version: 
1.0
Date Updated: 
08/06/2010
Author Name: 
Alessandro Ardolino

aa_rockGen 1.0 - maxscript procedural rock generator for production and real time environments.

Additional Info: 

aa_rockGen 1.0 - maxscript

procedural rock generator for production and real time environments.

-rock presets
-tweak-able parameters
-automatic low poly mesh generation, with bake-ready UVs
-normal and AO map generation

the script is now available for download.
tha script can be used for both personal and commercial purpose,
I you like it and found it useful, just let me know and let me see
some results :)

inspired by a tutorial of Sasha Henrichs published on Autodesk AREA.
you can find the original tutorial here: http://saschahenrichs.blogspot.com/2010/03/3dsmax-environment-modeling-1...

Video URL: 
AttachmentSize
aa_rockgenerator1x0.mse16.04 KB

Comments

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
alelink's picture

hi, you need to set an output

hi,
you need to set an output path for the textures, don't use the default one.

cecofuli's picture

Same problem here: When I hit

Same problem here:

When I hit the bake button it just gives me a very dark/diffuse black texture on the low poly rock. And no normal map generation, in any directory. I am using Max 2011 x64.

alelink's picture

Hi, as I stated in the

Hi,
as I stated in the email,
try to put the script outside the max folders.

TimothyDel's picture

The button was created as per

The button was created as per your instructions and it worked when I rebooted Max Design 2011 x64 on Win x64 Ultimate. However, every time I reboot Max now an "Error in the application occurred, Max will now close..." occurs. When I delete the aa_rockgenerator1x0.mcr file, Max boots fine. I do see the button actually have black text when booting (as opposed to being gray-ed out when I delete the file).

Running the aa_rockgenerator1x0.mse directly from MaxScript works fine.

Any ideas? Also, would it be easy to have the script run from a pulldown menu?

Here's the aa_rockgenerator1x0.mcr script in the same directory as the aa_rockgenerator1x0.mse file: C:\Program Files\Autodesk\3ds Max Design 2011\ui\macroscripts
Here's the file's content:

macroScript RockGenerator category:"aa_stoneworks" buttonText:"RockGenerator" toolTip:"Rock Generator" silenterrors:true
(
on execute do(
filein ((getDir #UI) + "\\MacroScripts\\aa_rockgenerator1x0.mse")
)

)

Thank you in advance,
Timothy

alelink's picture

have you choose an output

have you choose an output path before baking the maps?

coldy's picture

First off, great script looks

First off, great script looks awesome in high poly. But I can't seem to get the low poly with baked textures to work.

When I hit the bake button it just gives me a dark black texture on the low poly rock. I am using Max 2011 x64.

nomanrahid's picture

Thanks, i solved my

Thanks, i solved my problem.
sir its awesome.

alelink's picture

have you created the low poly

have you created the low poly mesh?

trixian's picture

I have not renamed anything.

I have not renamed anything. I hit create and then bake. Am I the only one that gets this error? It works fine on the stone placement tool.

alelink's picture

wow! what a wonderful color

wow! what a wonderful color texture :)

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.